Registrarse
Home
Foros
Miembros
Calendario
Normas
Ayuda

Foros de usuarios de openSUSE
Retroceder   ForoSUSE > Zona OpenSUSE > Portátiles y otros Dispositivos


Síguenos en Twitter Suscríbete a nuestras noticias Acompáñanos en Facebook

Respuesta
 
Herramientas Desplegado

Error repositorio Packman y Yast
  #1  
Antiguo 28-oct-2018, 14:19
Avatar de musleman
musleman musleman está desconectado
Aforado
 
Fecha de Ingreso: 30-noviembre-2015
Versión: Leap
Mensajes: 33
Agradecimientos: 33
Agradecido 5 Veces en 4 Mensajes
Poder de Credibilidad: 0
musleman está en el buen camino
Error repositorio Packman y Yast

Muy buenas...

Bueno, vamos a ver. Después de estar un tiempo sobreviviendo con el windows para acabar ( o intentarlo ) la tesis ( y no, no estoy en la Juan Carlos I ) he vuelto a instalar opensuse, porque es con el único linux que me encuetro cómodo.

Particiono mi HDD, le dejo la boot/efi, la swat, la / y la home, todo ello en ext4. Instalo el úlltimo leap que veo que está, el 15. Hasta ahí todo bien.

Una vez instalado, lo dejo que se actualice y reinicio. Bien, la bios me coge el grub2 y me deja elegir el SO con el que quiero empezar. Opensuse para seguir actualizando.

Busco en google qué hacer después de instalar opensuse 15 y me aparece https://www.diversidadyunpocodetodo....nsuse-leap-15/

Me voy a los repos a través de Yast y borro los Debug y los sources, además del medio de instalación. Y me dispongo a agregar Packman, nvidia y libdvdcss, que son los que agrego. Una vez añadidos, me viene el problema. Cambio la preferencia a Packman a 70 y le digo a Yast en editar que me ponga el nombre de Packman_Repository, para poder llamarlo desde consola, pues si no se le cambia el nombre no lo reconoce, según el manuel y según recuerdo yo. Nada, nunca me cambia el nombre. Ni a la primera ni nunca. Reinicio y nada. Lo quito de nuevo y nada.

Entonces me voy a terminal. Veo esta web sobre zypper https://es.opensuse.org/Zypper e intento cambiar el alias y el nombre mediante

Para el alias:
Código:
zypper nr XX repo-XXXXXXXXXXXXXX
Para el nombre:
Código:
zypper mr XX repo-XXXXXXXXXXXXX
Y luego le intento establecer la prioridad del oficial a packman

Código:
zypper dup --from Packman_Repository
Y ahí me quedé. Nada, error al canto constante. Si intento realizar un cambio de proveedor a la hora de instalar algo desde Yast, me da error Packman...

He vuelto a hacer una instación desde 0 por si había errores en la iso. Termino y todo sigue igual. No soy capaz de renombrar para establecer prioridad.

Alguna sugerencia....
Responder Citando
  #2  
Antiguo 29-oct-2018, 03:25
Avatar de mikrios
mikrios mikrios está desconectado
Miembro FOROSuSE
 
Fecha de Ingreso: 02-marzo-2013
Ubicación: Lat. 27.994547-Lon -15.405127-160m nivel del mar
Versión: 13.1-2,TW,Leap
Mensajes: 4.827
Agradecimientos: 2.033
Agradecido 1.523 Veces en 1.280 Mensajes
Poder de Credibilidad: 10
mikrios llegará a ser famoso muy pronto
Hola:


Comprueba que las fuentes del teclado, son correctas.

Dese repositorios yast , borra el medio de instalación, una vez finalizado esta.

Cuando añadas packman ,puedes ponerle el alias que quieras, y si tienes dudas de el enlace, copia este en una pagina vacía de firefox, y esta de redirige bien, es que es mas o menos correcta .

de todas formas te añado los mirros, ahí están todos, incluido el de los repos : "http://packman.links2linux.org/mirrors", puedes poner varios, si ves que hay problemas temporales en alguno de ellos, o ponerle distintas prefrencias 70, 77,etc (nº bajo, prioridad alta) .

Cuando vayas a instalar algo, procura seleccionar las 2 opciones que quedan : limpiar durante la eliminación de paquetes y cambio de proveedor.

También cuando añades los repositorios, suele salir una key, donde te pregunta si confias en ella, le das que si .

Normalmente los problemas en repos son temporales, excepto, algunos pocos, que siempre arreglan en el momento.


Te dejo un enlace a zypper, para que compruebes que los que hayas puesto, estén ok : "https://es.opensuse.org/Zypper" ( mis enlaces están entre comillas, copias lo que están ahí y lo pegas en la barra del navegador, es para no poner muchos enlaces activos en los post ) .

Los repos que tu crees que no son necesarios, puedes quitarle la auto actualización, e incluso desactivarlo, eso por si un día necesitas algo.

También puedes hacer el dup ( en TW no hay problema) una vez finalizado la instalación, ya cuando añades muchos repos, creo que es mejor usar up, la secuencia puede ser así zypper refs , zypper ref y zypper up (sobre todo si hay algún problema de cache) .

Cuando solo es una aplicación la que falla al actualizarse, y no te deja hacer actualización de los demás, puedes usar pakagekit (el plasmoide de la barra de tareas), entonces marcas ahí el problematico y actualizas los demás.

Saludos cordiales ,
Responder Citando
El Siguiente Usuario Ha Dado las Gracias a mikrios Por Este Mensaje:
musleman (29-oct-2018)
  #3  
Antiguo 29-oct-2018, 10:37
Avatar de DiabloRojo
DiabloRojo DiabloRojo está desconectado
Super Moderador
 
Fecha de Ingreso: 19-marzo-2005
Ubicación: En un lugar del planeta Tierra
Versión: La ultima estable
Mensajes: 17.016
Agradecimientos: 635
Agradecido 2.705 Veces en 1.840 Mensajes
Poder de Credibilidad: 10
DiabloRojo llegará a ser famoso muy pronto
El nombre le puedes poner con espacios en blanco sin problemas "Repositorio Packman" y zypper automáticamente le cambia los espacios en blanco por guines bajos '_'.

Danos la salida del comando zypper lr -upPE y envuelve su salida con QUOTE
http://www.forosuse.org/forosuse/misc.php?do=bbcode
__________________
NORMAS A CUMPLIR EN LOS FOROS (Lectura obligatoria) Lo siento, no contesto privados sobre problemas con GNU/Linux.
Síguenos en TWITTER y en FACEBOOK
Código:
Buscador de   Alojamiento      Alojamiento     Otros
 paquetes:    de imágenes:     de ficheros:    buscadores:
Search        TinyPic          Ifile Wuala     Simple y Facil
Webpinstant   Paste Suse       SendSpace       TextSnip  Cl1p
Responder Citando
El Siguiente Usuario Ha Dado las Gracias a DiabloRojo Por Este Mensaje:
musleman (29-oct-2018)
  #4  
Antiguo 29-oct-2018, 12:30
Avatar de musleman
musleman musleman está desconectado
Aforado
 
Fecha de Ingreso: 30-noviembre-2015
Versión: Leap
Mensajes: 33
Agradecimientos: 33
Agradecido 5 Veces en 4 Mensajes
Poder de Credibilidad: 0
musleman está en el buen camino
Aquí tienes la respuesta de zypper lr -upPE

Código:
# | Alias                               | Nombre                            | Habilitado | Comprobación GPG | Actualizar | Prioridad | URI                                                                                   
--+-------------------------------------+-----------------------------------+------------+------------------+------------+-----------+---------------------------------------------------------------------------------------
4 | packman.inode.at-suse               | Packman Repository                | Sí         | (r ) Sí          | Sí         |   70      | http://packman.inode.at/suse/openSUSE_Leap_15.0/                                      
1 | download.nvidia.com-leap            | nVidia Graphics Drivers           | Sí         | (r ) Sí          | Sí         |   99      | https://download.nvidia.com/opensuse/leap/15.0                                        
2 | http-download.opensuse.org-da2b620f | X11:RemoteDesktop:x2go            | Sí         | (r ) Sí          | Sí         |   99      | http://download.opensuse.org/repositories/X11:/RemoteDesktop:/x2go/openSUSE_Leap_15.0/
3 | opensuse-guide.org-repo             | Libdvdcss Repository              | Sí         | (r ) Sí          | Sí         |   99      | http://opensuse-guide.org/repo/openSUSE_Leap_15.0/                                    
5 | repo-non-oss                        | openSUSE-Leap-15.0-Non-Oss        | Sí         | (r ) Sí          | Sí         |   99      | http://download.opensuse.org/distribution/leap/15.0/repo/non-oss/                     
6 | repo-oss                            | openSUSE-Leap-15.0-Oss            | Sí         | (r ) Sí          | Sí         |   99      | http://download.opensuse.org/distribution/leap/15.0/repo/oss/                         
7 | repo-update                         | openSUSE-Leap-15.0-Update         | Sí         | (r ) Sí          | Sí         |   99      | http://download.opensuse.org/update/leap/15.0/oss/                                    
8 | repo-update-non-oss                 | openSUSE-Leap-15.0-Update-Non-Oss | Sí         | (r ) Sí          | Sí         |   99      | http://download.opensuse.org/update/leap/15.0/non-oss/
Al mensaje de mikrios todavía no tengo una respuesta pues estoy comprobando varias de las cosas que él comenta.

Saludos.

Última edición por musleman; 29-oct-2018 a las 15:34
Responder Citando
  #5  
Antiguo 29-oct-2018, 13:22
Avatar de Krovikan
Krovikan Krovikan está desconectado
Miembro Junior
 
Fecha de Ingreso: 16-noviembre-2010
Ubicación: Delante del ordenador
Versión: Leap 15
Mensajes: 735
Agradecimientos: 309
Agradecido 174 Veces en 150 Mensajes
Poder de Credibilidad: 9
Krovikan está en el buen camino
@musleman, creo que DR quiso decir que lo envolvieras en un CODE que se ve mejor.


Un trocito del mio entre los tags CODE



Código:
#   | Alias                           |  Nombre                                   | Habilitado | Comprobación GPG  | Actualizar | Prioridad |  URI                                                                                             
---+---------------------------------+------------------------------------------+------------+------------------+------------+-----------+------------------------------------------------------------------------------------------------
 8  | Packman                         |  Packman                                  | Sí         | (r ) Sí           | Sí         |   70      |  http://packman.inode.at/suse/openSUSE_Leap_15.0/                                                
10 | Qt5                             |  Qt5                                      | Sí         | (r ) Sí           | Sí         |   91      |  http://download.opensuse.org/repositories/KDE:/Qt5/openSUSE_Leap_15.0/                          
 2 | Frameworks_5                    | Frameworks  5                             | Sí         | (r ) Sí          |  Sí         |   92      |  http://download.opensuse.org/repositories/KDE:/Frameworks5/openSUSE_Leap_15.0/                  
 3 | KDE_Apps                        | KDE  Apps                                 | Sí         | (r ) Sí          |  Sí         |   93      |  http://download.opensuse.org/repositories/KDE:/Applications/KDE_Frameworks5_openSUSE_Leap_15.0/
 4  | KDE_Extra                       | KDE  Extra                                | Sí         | (r ) Sí          |  Sí         |   94      |  http://download.opensuse.org/repositories/KDE:/Extra/openSUSE_Leap_15.0/

Se lee mucho mejor además de tener los encabezados de las columnas que no pusistes.




Saludos
Responder Citando
El Siguiente Usuario Ha Dado las Gracias a Krovikan Por Este Mensaje:
musleman (29-oct-2018)
  #6  
Antiguo 29-oct-2018, 21:06
Avatar de DiabloRojo
DiabloRojo DiabloRojo está desconectado
Super Moderador
 
Fecha de Ingreso: 19-marzo-2005
Ubicación: En un lugar del planeta Tierra
Versión: La ultima estable
Mensajes: 17.016
Agradecimientos: 635
Agradecido 2.705 Veces en 1.840 Mensajes
Poder de Credibilidad: 10
DiabloRojo llegará a ser famoso muy pronto
Cita:
Iniciado por musleman Ver Mensaje
Aquí tienes la respuesta de zypper lr -upPE
No veo que el enlace del Packman este roto, esta perfectos los repos.

No se cual es el fallo del repositorio, ejecuta el comando de abajo y si sale fallos copia su salida y reportala con CODE.
sudo zypper ref && sudo zypper up

Te pongo un ejemplo:
Código:
sudo zypper ref && sudo zypper up
[sudo] password for root: 
El repositorio 'Emulators (openSUSE_Leap_15.0)' está actualizado.                                                                                               
El repositorio 'Google Chrome' está actualizado.                                                                                                                
El repositorio 'Opera repo rpm' está actualizado.                                                                                                               
El repositorio 'openSUSE-Leap-15.0-Non-Oss' está actualizado.                                                                                                   
El repositorio 'openSUSE-Leap-15.0-Update-Non-Oss' está actualizado.                                                                                            
El repositorio 'openSUSE-Leap-15.0-Update-Oss' está actualizado.                                                                                                
El repositorio 'Libdvdcss Repository' está actualizado.                                                                                                         
El repositorio 'Packman Repository' está actualizado.                                                                                                           
El repositorio 'openSUSE-Leap-15.0-Oss' está actualizado.                                                                                                       
El repositorio 'Sublime Text - x86_64 - Stable' está actualizado.                                                                                               
El repositorio 'VirtualBox for openSUSE 13.2 / Leap 42.1' está actualizado.                                                                                     
El repositorio 'vivaldi' está actualizado.                                                                                                                      
El repositorio 'Cross-toolchain for 32-bit windows and 32-bit windows packages (openSUSE_Leap_15.0)' está actualizado.                                          
El repositorio 'Cross-toolchain for 64-bit windows and 64-bit windows packages (openSUSE_Leap_15.0)' está actualizado.                                          
Todos los repositorios han sido actualizados.
Cargando datos del repositorio...
Leyendo los paquetes instalados...

No hay nada que hacer.
__________________
NORMAS A CUMPLIR EN LOS FOROS (Lectura obligatoria) Lo siento, no contesto privados sobre problemas con GNU/Linux.
Síguenos en TWITTER y en FACEBOOK
Código:
Buscador de   Alojamiento      Alojamiento     Otros
 paquetes:    de imágenes:     de ficheros:    buscadores:
Search        TinyPic          Ifile Wuala     Simple y Facil
Webpinstant   Paste Suse       SendSpace       TextSnip  Cl1p
Responder Citando
  #7  
Antiguo 31-oct-2018, 13:19
Avatar de musleman
musleman musleman está desconectado
Aforado
 
Fecha de Ingreso: 30-noviembre-2015
Versión: Leap
Mensajes: 33
Agradecimientos: 33
Agradecido 5 Veces en 4 Mensajes
Poder de Credibilidad: 0
musleman está en el buen camino
Lo mío con leap 15 no es amor a primera vista, desde luego.

Después de narrar lo anterior hice una instalación de 0 y bien. Pude añadir los repos desde yast, cambiar el nombre, etc...Añadí packman, libdvdcss y nvidia. Configuro kde como a mi me gusta y reinicio. Todo parece ir perfecto. Bien. Apago el pc y a la mañana siguiente enciendo el portátil, elijo leap 15 y....tachannnn....se quedan las letras de la carga haciendo parpadeos constantes, como si fuera una bombilla a punto de morirse.

Después de tomarme un café y respirar, decido grabar de nuevo la iso con rufus. Instalar de nuevo y volver a probar. Hago lo mismo y justo al rato...tachannn...el mismo parpadeo. Vamos, que si le enchufo un cable y le pongo una lámpara de esas de disco, pongo mi salón como una pista de baile. Y ahí se queda.

Pues nada, no he sido de los que se rinden. Tengo pendiente leerme algún manual para saber utilizar el modo rescue o parecido para poder apañarme sin tener que instalar desde 0, que seguro que algo puedo hacer.

He vuelto a instalar pero ahora, el único repo que no añado es el privativo de nvidia. He leído por los foros que con el nouveau tengo suficiente. Y lo siento por krovikan, pero no me apetece estar haciendo su método cada vez que se actualice el kernel o el servidor gráfico. Eso sí, su trabajo de 10. También he visto esta web, pero de momento todo va bien.

Mis repos ahora:

Código:
linux-r5ov:/home/carlos # zypper lr -upPE
# | Alias                   | Nombre                            | Habilitado | Comprobación GPG | Actualizar | Prioridad | URI                                                              
--+-------------------------+-----------------------------------+------------+------------------+------------+-----------+------------------------------------------------------------------
2 | packman.inode.at-suse   | Packman Repository                | Sí         | (r ) Sí          | Sí         |   70      | http://packman.inode.at/suse/openSUSE_Leap_15.0/                 
1 | opensuse-guide.org-repo | Libdvdcss Repository              | Sí         | (r ) Sí          | Sí         |   99      | http://opensuse-guide.org/repo/openSUSE_Leap_15.0/               
3 | repo-non-oss            | openSUSE-Leap-15.0-Non-Oss        | Sí         | (r ) Sí          | Sí         |   99      | http://download.opensuse.org/distribution/leap/15.0/repo/non-oss/
4 | repo-oss                | openSUSE-Leap-15.0-Oss            | Sí         | (r ) Sí          | Sí         |   99      | http://download.opensuse.org/distribution/leap/15.0/repo/oss/    
5 | repo-update             | openSUSE-Leap-15.0-Update         | Sí         | (r ) Sí          | Sí         |   99      | http://download.opensuse.org/update/leap/15.0/oss/               
6 | repo-update-non-oss     | openSUSE-Leap-15.0-Update-Non-Oss | Sí         | (r ) Sí          | Sí         |   99      | http://download.opensuse.org/update/leap/15.0/non-oss/
Código:
linux-r5ov:/home/carlos # sudo zypper ref && sudo zypper up
El repositorio 'Libdvdcss Repository' está actualizado.                                                
El repositorio 'Packman Repository' está actualizado.                                                  
El repositorio 'openSUSE-Leap-15.0-Non-Oss' está actualizado.                                          
El repositorio 'openSUSE-Leap-15.0-Oss' está actualizado.                                              
El repositorio 'openSUSE-Leap-15.0-Update' está actualizado.                                           
El repositorio 'openSUSE-Leap-15.0-Update-Non-Oss' está actualizado.                                   
Todos los repositorios han sido actualizados.
Cargando datos del repositorio...
Leyendo los paquetes instalados...

No hay nada que hacer.
Código:
linux-r5ov:/home/carlos # hwinfo --gfxcard
12: PCI 02.0: 0300 VGA compatible controller (VGA)              
  [Created at pci.378]
  Unique ID: _Znp.A5tYWqWPOk9
  SysFS ID: /devices/pci0000:00/0000:00:02.0
  SysFS BusID: 0000:00:02.0
  Hardware Class: graphics card
  Model: "Intel HD Graphics 530"
  Vendor: pci 0x8086 "Intel Corporation"
  Device: pci 0x191b "HD Graphics 530"
  SubVendor: pci 0x17aa "Lenovo"
  SubDevice: pci 0x380a 
  Revision: 0x06
  Driver: "i915"
  Driver Modules: "i915"
  Memory Range: 0xd0000000-0xd0ffffff (rw,non-prefetchable)
  Memory Range: 0xc0000000-0xcfffffff (ro,non-prefetchable)
  I/O Ports: 0xe000-0xe03f (rw)
  Memory Range: 0x000c0000-0x000dffff (rw,non-prefetchable,disabled)
  IRQ: 128 (65115 events)
  Module Alias: "pci:v00008086d0000191Bsv000017AAsd0000380Abc03sc00i00"
  Driver Info #0:
    Driver Status: i915 is active
    Driver Activation Cmd: "modprobe i915"
  Config Status: cfg=new, avail=yes, need=no, active=unknown

25: PCI 100.0: 0302 3D controller
  [Created at pci.378]
  Unique ID: VCu0.QLkCOcCTL73
  Parent ID: vSkL.OR7l9wEpxI6
  SysFS ID: /devices/pci0000:00/0000:00:01.0/0000:01:00.0
  SysFS BusID: 0000:01:00.0
  Hardware Class: graphics card
  Model: "nVidia GM107M [GeForce GTX 950M]"
  Vendor: pci 0x10de "nVidia Corporation"
  Device: pci 0x139a "GM107M [GeForce GTX 950M]"
  SubVendor: pci 0x17aa "Lenovo"
  SubDevice: pci 0x380b 
  Revision: 0xa2
  Driver: "nouveau"
  Driver Modules: "nouveau"
  Memory Range: 0xd1000000-0xd1ffffff (rw,non-prefetchable)
  Memory Range: 0xa0000000-0xafffffff (ro,non-prefetchable)
  Memory Range: 0xb0000000-0xb1ffffff (ro,non-prefetchable)
  I/O Ports: 0xd000-0xdfff (rw)
  IRQ: 127 (37 events)
  Module Alias: "pci:v000010DEd0000139Asv000017AAsd0000380Bbc03sc02i00"
  Driver Info #0:
    Driver Status: nouveau is active
    Driver Activation Cmd: "modprobe nouveau"
  Config Status: cfg=new, avail=yes, need=no, active=unknown
  Attached to: #21 (PCI bridge)

Primary display adapter: #12
Así a bote pronto, hasta que no me empape bien el tema de la gráfica, de un archivo por ahí que da la lata, el drm-kmp-default, que parece que habría que quitarlo...En fin, de momento creo que lo dejo así, sin drivers privativos para probar si el portátil falla.

Si alguien tiene alguna sugerencia...encantando.

Saludos
Responder Citando
Respuesta

Marcadores


(0 miembros y 1 visitantes)
 
Herramientas
Desplegado

Normas de Publicación
No puedes crear nuevos temas
No puedes responder mensajes
No puedes subir archivos adjuntos
No puedes editar tus mensajes

Los Códigos BB están Activado
Las Caritas están Activado
[IMG] está Activado
El Código HTML está Desactivado

Ir al Foro

Temas Similares
Tema Autor Foro Respuestas Último mensaje
error repositorios jjers Instalación y Actualizaciones 35 07-nov-2017 03:42
bluray Linux jolop Hardware 39 18-ene-2016 05:42
Problema para reproducir MP4 y RMVB surrender Multimedia 26 07-jun-2015 06:04
Otro "The following 48 package updates will NOT be installed" al actualizar openSUSE moshpirit Software 12 01-mar-2015 23:39
KMIX - KOPETE - AMAROK ... ¿No quieren estar en la barra de tareas? manelleon Escritorios: KDE, Gnome, otros... 14 10-may-2011 15:08



Síguenos en Twitter Suscríbete a nuestras noticias Acompáñanos en Facebook


La franja horaria es GMT +2. Ahora son las 05:41.
Powered by vBulletin™
Copyright © vBulletin Solutions, Inc. All rights reserved.

Esta página está bajo una licencia de Creative Commons, salvo que no se indique lo contrario.
Creative Commons License

Valid CSS!

Diseño por:Designed by: vbdesigns.devbdesigns.de 
Contáctenos - ForoSUSE - Archivo - Declaración de Privacidad - Arriba